Nama-nama Pilihan Bagi Anak-anak

Iklan Darul Nu'man

Nama-nama Pilihan Bagi Anak-anak

Menurut sebuah hadith dari Rasulullah SAW bahawa nama yang baik diberikan kepada anak-anak dari kaum muslimin ialah nama para nabi. Manakala yang lebih afdhal (utama) dan disukai oleh Allah SWT ialah Abdullah dan Abdur Rahman. Sedangkan nama yang paling tepatnya ialah Harith dan Hammam. Nama yang paling buruk pula ialah Harb (perang) dan Murrah (pahit).

Adalah menjadi kewajipan bagi kedua ibu bapa untuk memberikan nama yang baik kepada anak-anaknya. Pada dasarnya, memberikan nama yang baik kepada anak-anak bukanlah wajib hukumnya. Namun, jika ditinjau dari segi kesan dan akibat yang timbul daripadanya, maka hukumnya akan beralih menjadi wajib secara sendirinya. Oleh itu, berhati-hatilah dalam memilih dan memberikan nama kepada anak-anak. Carilah nama yang dianjurkan oleh Islam atau sekurang-kurangnya carilah nama yang membawa maksud yang baik dan sedap di dengar oleh telinga.

  1. Nama-nama pilihan anak lelaki.
  2. Nama-nama dilarang dalam Islam.

*Untuk mendapatkan senarai nama-nama pilihan anak perempuan, sila dapatkan buku "Amalan ketika mengadung & setelah bersalin serta panduan menamakan bayi" di kedai-kedai yang berhampiran.

Dipetik Dari Buku:
Amalan ketika mengandung & setelah bersalin serta panduan menamakan bayi.
Pengarang:
Abu Afiqah.
Penyalur Inspirasi Ummah
All Right Reserved Darul Nu'man © EMAG 1991


HTMLHelp File Created Using:

Web2HTMLHelp 		Free To Download From:
http://www.web2htmlhelp.co.uk

Also Available:
HTMLHelp ePublisher
HTMLHelp eDocument Creation Made Easy

Free To Download From:
http://www.htmlhelp-epublisher.co.uk

[ Back ]


Nama-nama Pilihan Bagi Anak-anak

Nama-nama Pilihan Bagi Anak-anak

Menurut sebuah hadith dari Rasulullah SAW bahawa nama yang baik diberikan kepada anak-anak dari kaum muslimin ialah nama para nabi. Manakala yang lebih afdhal (utama) dan disukai oleh Allah SWT ialah Abdullah dan Abdur Rahman. Sedangkan nama yang paling tepatnya ialah Harith dan Hammam. Nama yang paling buruk pula ialah Harb (perang) dan Murrah (pahit).

Adalah menjadi kewajipan bagi kedua ibu bapa untuk memberikan nama yang baik kepada anak-anaknya. Pada dasarnya, memberikan nama yang baik kepada anak-anak bukanlah wajib hukumnya. Namun, jika ditinjau dari segi kesan dan akibat yang timbul daripadanya, maka hukumnya akan beralih menjadi wajib secara sendirinya. Oleh itu, berhati-hatilah dalam memilih dan memberikan nama kepada anak-anak. Carilah nama yang dianjurkan oleh Islam atau sekurang-kurangnya carilah nama yang membawa maksud yang baik dan sedap di dengar oleh telinga.

  1. Nama-nama pilihan anak lelaki.
  2. Nama-nama dilarang dalam Islam.

*Untuk mendapatkan senarai nama-nama pilihan anak perempuan, sila dapatkan buku "Amalan ketika mengadung & setelah bersalin serta panduan menamakan bayi" di kedai-kedai yang berhampiran.

Dipetik Dari Buku:
Amalan ketika mengandung & setelah bersalin serta panduan menamakan bayi.
Pengarang:
Abu Afiqah.


Nama-nama dilarang Dalam Islam (Panduan menamakan anak)

Nama-nama dilarang Dalam Islam

Abkam | = | Tidak celik, buta
Abiqah | = | Hamba yang lari dari tuannya
Afinah | = | Yang bodoh
Asyar | = | Paling jahat
Asyirah | = | Yang tidak bersyukur atas nikmat
Amah | = | Hamba suruhan perempuan
Baghiah | = | Yang zalim, jahat
Bahimah | = | Binatang
Balidah | = | Yang bodoh, bebal
Bakiah | = | Yang menangis, merengek
Baqarah | = | Lembu Betina
Batilah | = | Yang batil, tidak benar
Dabbah | = | Binatang
Dahriyah | = | Yang mempercayai alam wujud dengan sendirinya
Dahisyah | = | Goncang, stress
Darakah | = | Kedudukan yang rendah
Daniyah | = | Yang lemah dan hina
Dami'ah | = | Yang mengalir air matanya
Fasidah | = | Yang rosak, yang binasa
Fasiqah | = | Yang jahat, si fasik
Fasyilah | = | Gagal, kalah
Fajirah | = | Yang jahat, yang berdosa
Faji'ah | = | Kecelakaan
Ghafilah | = | Yang lalai, yang leka
Ghailah | = | Kecelakaan, bencana
Ghaibah | = | Hilang
Ghasibah | = | Perampas, perompak
Ghamitah | = | Yang tidak mensyukuri nikmat
Ghawiah | = | Yang sesat, yang mengikut hawa nafsu
Haqidah | = | Yang dengki
Hasidah | = | Yang hasad
Hazinah | = | Yang sedih
Huzn | = | Kesedihan
Khabithah | = | Yang jahat, yang keji
Khali'ah | = | Yang tidak segan silu, mengikut hawa nafsu
Khati'ah | = | Yang bersalah, yang berdosa
Khasirah | = | Yang rugi
Khamrah | = | Arak
Jariah | = | Hamba suruhan perempuan
Jafiah | = | Yang tidak suka berkawan
Kaibah | = | Yang sedih
Kafirah | = | Yang kafir, yang ingkar
Kamidah | = | Yang hiba, yang sangat berduka
Kazibah | = | Pendusta, pembohong
Lahab | = | Bara api
Laghiah | = | sia-sia, tidak berfaedah
La'imah | = | Yang tercela
Lainah | = | Yang terkutuk
Lahifah | = | Yang sedih, menyesal dan dizalimi
Maridah | = | Yang menderhaka
Majinah | = | Yang bergurau senda tanpa perasaan malu
Majusiah | = | Agama menyembah api atau matahari
munafikah | = | Yang munafik
Musibah | = | Celaka, bencana, kemalangan
Nariah | = | Api
Nasyizah | = | Yang menderhaka dan melawan suami
Najisah | = | Yang najis dan kotor
Qabihah | = | Yang buruk, hodoh
Qatilah | = | Pembunuh
Qasitah | = | Yang melampaui batasan dan menyeleweng dari kebenaran
Qazurah | = | Kejahatan, perzinaan
Rajimah | = | Yang direjam, yang dilaknat
Razi'ah | = | Kecelakaan, musibah
Razilah | = | Yang keji dan hina
Sakitah | = | Yang jatuh, yang hina, yang jahat
Safilah | = | Yang rendah dan hina
Sahiah | = | Yang pelupa
Sakirah | = | Pemabuk
Syafihah | = | Yang bodoh
Syaridah | = | Yang diusir
Syaqiyah | = | Yang menderita
Syarrul Bariyyah | = | Sejahat-jahat manusia
Syani'ah | = | Yang buruk
Syarisah | = | Yang buruk akhlak
Syatimah | = | Maki hamun
Syariqah | = | Pencuri
Talifah | = | Yang rosak, yang binasa
Tarbiyah | = | Yang papa kedana
Tarikah | = | Anak dara tua
Tafihah | = | Karut
Talihah | = | Yang tidak baik
Yaisah | = | Yang berputus asa
Yabisah | = | Yang kering, yang sedikit kebaikannya
Wahinah | = | Penakut
Waqihah | = | Yang kurang sopan dan malu
Wasikhah | = | Yang kotor
Wasyiah | = | Yang mengumpat, yang mengadu dombakan orang
Wahimah | = | Yang lemah
Wahiah | = | Yang lemah, yang jatuh, yang buruk
Wajilah | = | Penakut
Wailah | = | Bencana, keburukan
Waqi'ah | = | Pertempuran dalam peperangan, umpatan
Zalijah | = | Kebinasaan
Zalilah | = | Yang hina
Zalimah | = | Yang zalim
Zaniyah | = | Penzina, pelacur
Zufafah | = | Racun pembunuh

^ Kembali ke atas ^

^ Kembali ke senarai nama pilihan ^


Nama-nama Pilihan Anak Lelaki

- A - B - C - D - E - F - G - H - I - J - K - L - M - N - O - P - Q - R - S - T - U - V -
- W - X - Y - Z -

Balyan | = | Nama auliya
Bahran | = | Bercahaya
Baqir | = | Sangat pandai, terpelajar
Basim | = | Gembira, tersenyum
Basit | = | Pereka, pembuat
Bahjat | = | Kegemilangan
Badar | = | Bulan penuh
Bassam | = | Suka tersenyum
Badiuzzaman | = | Keindahan semasa
Bazil | = | Yang pandai
Badrulmunir | = | Bulan bercahaya
Badran | = | Bulan penuh (purnama)
Badri | = | Bulan purnamaku
Basyirun | = | Yang melihat
Badrun | = | Bulan purnama
Badruddin | = | Bulan purnama agama
Baghawi | = | Nisbah
Bahauddin | = | Sinaran agama
Bahadur | = | Berani, kuat
Bahij | = | Yang indah menawan
Bahjan | = | Cemerlang
Bahri | = | Kegemilanganku
Bahruddin | = | Sinaran agama
Bayiyuddin | = | Sinaran agama
Bahzi | = | Pembelaku
Bais | = | Tentera
Bakri | = | Kemudaanku
Bakhit | = | Yang bertuah
Bakhtiar | = | Yang bahagia
Banin | = | Yang bijak, gigih
Barra | = | Yang bersih
Barzun | = | Utama, berani
Baslan | = | Keberanian
Basil | = | Berani
Basir | = | Bijak, melihat
Basyar | = | Pembawa berita baik
Basyir | = | Penyampai berita gembira
Bahlawan | = | Pendaki gunung
Basri | = | Penglihatanku
Basirun | = | Yang melihat
Bazli | = | Kebijaksanaanku, kepakaranku
Bazilin | = | Yang menyumbang
Bunyamin | = | Nama saudara nabi yusuf
Bilal | = | Nama saabat nabi, titisan embun
Biruni | = | Nama ulama besar
Bisyari | = | Kegembiraan
Bisyrun | = | Berita gembira
Burhan | = | Alasan, bukti
Burhanuddin | = | Bukti agama
Busairi | = | Nisbah
Busrain | = | Kesegaran
Bustani | = | Tamanku
Buraidah | = | Kesejukan
Busran | = | Khabar gembira


- W - X - Y - Z -

Tiada nama yang bersesuaian


- W - X - Y - Z -

Daim | = | Kekal abadi
Daisam | = | Lemah lembut
Dailami | = | Askarku
Danial | = | Nama nabi
Daiyan | = | Hakim, pembalas
Danish | = | Pengetahuan, bijak
Darwisy | = | Warak
Dasuki | = | Keindahanku, cahayaku
Dawani | = | Nisbah
Daud | = | Nama nabi
Din | = | Agama, kepercayaan
Dini | = | Agamaku
Dhia | = | Sinaran
Dhiyauddin | = | Sinaran agama
Dhiyaulhaq | = | Sinaran kebenaran
Dhiaurrahman | = | Sinaran yang pengasih (Allah)
Dhomrah | = | Nama sahabat nabi Muhammad SAW
Dhabit | = | Yang kuat ingatan
Dhamiri | = | Jiwaku
Dubies | = | Nama pahlawan arab
Durrani | = | Permataku


- W - X - Y - Z -

Fadlan | = | Keutamaan
Fadil | = | Yang mulia
Fadli | = | Kelebihanku, ihsanku
Fadlin | = | Keutamaan
Fadil | = | Yang utama
Fadal | = | Keutamaan
Fadlullah | = | Kelebihan Allah
Fahad | = | Harimau bintang
Fahim | = | Yang faham
Fahmi | = | Kefahamanku
Fahman | = | Kefahaman
Faid | = | Yang tetap, yang berhasil
Faiq | = | Tertinggi, utama
Faqih | = | Yang mengerti
Faisal | = | Penyelesaian
Faiz | = | Berjaya
Fajar | = | Cahaya putih
Fakhri | = | Kemegahanku
Fakhruddin | = | Kebanggaan agama
Falah | = | Kejayaan
Fakhrullah | = | Kemegahan Allah
Farhan | = | Girang, gembira
Farhat | = | Kegembiraan
Farid | = | Yang istimewa, permata, tiada bandingan
Fariduddin | = | Permata agama, keistimewaan
Fannani | = | Seniman
Faris | = | Yang alim, ahli penunggang kuda
Faruq | = | Pembeza antara benar dan salah
Fathi | = | Pembukaanku, kemenanganku
Farhun | = | Kegembiraan
Fathuddin | = | Pembukaan, kejayaan agama
Fathul Islam | = | Pembuka, kejayaan Islam
Fathullah | = | Pembukaan, Kejayaan Allah
Fatih | = | Pembuka, perintis
Fathurrahman | = | Pembukaan, Kejayaan Allah yang pengasih
Fattah | = | Penakluk
Fasahat | = | Fasih, lancar
Fasih | = | Yang fasih
Fauzi | = | Kejayaanku
Fauzan | = | Kejayaan
Fawwaz | = | Berjaya
Fayyadh | = | Murah hati
Fidai | = | Pengorbanan
Fikri | = | Fikiranku
Firas | = | Kecerdikan, celik akal
Firdaus | = | Nama syurga
Fitri | = | Semulajadi
Fuad | = | Hati, jiwa
Fuadi | = | Jiwaku
Furqan | = | Bukti, kenyataan
Fudail | = | Kelebihanku, kemuliaan


- W - X - Y - Z -

Ghadi | = | Singa
Ghaffar | = | Sedia mengampuni, lembut hati
Ghaffur | = | Pengampun
Ghali | = | Mahal
Ghalib | = | Yang menang
Ghanim | = | Yang mencapai kejayaan
Ghanimi | = | Kejayaanku
Ghani | = | Kaya, mewah
Ghassan | = | Kecantikan dan kelembutan remaja
Ghaisan | = | Rupawan
Ghaisani | = | Cantik dan muda
Ghaus | = | Pertolongan
Ghazali | = | Pelandukku
Ghazlan | = | Tenunan
Ghazi | = | Pejuang
Ghailan | = | Nama sahabat nabi Muhammad SAW
Ghufran | = | Keampunan
Ghulwani | = | Keremajaan dan kecergasan
Ghulan | = | Remaja


- W - X - Y - Z -

Habbab | = | Yang mengasihi
Habib | = | Kekasih
Habri | = | Kegembiraanku
Hadi | = | Yang memimpin
Hadwan | = | Ketenangan
Hadrami | = | Nisbah
Hadari | = | Maju, bertamadun, penduduk bandar
Haddad | = | Lautan
Hadif | = | Yang mempunyai matlamat
Hfiy | = | Yang memuliakan
Hafiz | = | Penjaga, pelindung
Hafuza | = | Pemberi semangat
Hafizuddin | = | Pemelihara agama
Hail | = | Yang disegani
Hajib | = | Pendinding
Hajim | = | Pelindung
Hajid | = | Yang solat malam
Hakam | = | Pengadil
Hakim | = | Bijaksana
Hakmani | = | Pengadil
Hajaj | = | Pelawat
Hamad | = | Terpuji
Hamas | = | Berani
Hamdan | = | Terpuji
Hamdawi | = | Yang memuji
Hamdi | = | Pujianku
Hamdun | = | Terpuji
Hamid | = | Yang memuji
Hamud | = | Yang banyak memuji
Hamiduddin | = | Pujian agama
Haiman | = | Menguasai
Hamim | = | Teman karib
Hamimi | = | Teman karibku
Hamlan | = | Berdiri sendiri
Hamiz | = | Cerdik, kuat, tampan
Hamsyari | = | Anak jati watan
Hamizan | = | Cerdik, kuat, tampan
Hammani | = | Pemberi semangat
Hamzah | = | Kebijaksanaan
Hamzi | = | Ketegasanku
Hanafi | = | Kelurusanku
Hanania | = | Dikasihi Allah
Haitham | = | Yang mudah
Hanif | = | Yang lurus
Hanin | = | Kesayangan
Hanis | = | Berani, warak
Hanun | = | Kesayangan
Haidar | = | Berani, singa
Haikal | = | Pokok yang besar dan subur
Haimadi | = | Pujian agama
Haiman | = | Yang cinta, asyik
Hariri | = | Suteraku, nisbah
Harraz | = | Yang amat warak
Haris | = | Pengawal, pelindung
Harith | = | Kuat, berusaha
Hariz | = | Pemelihara
Harzan | = | Penjagaan
Harun | = | Nama nabi
Hasan | = | Lawa, segak
Hassan | = | Sangat baik
Hasbi | = | Yang memadai bagiku
Hasbullah | = | Jaminan Allah
Hasib | = | Berketurunan mulia
Hasnawi | = | Kecantikan
Hasif | = | Kemas, rapi
Hasnun | = | Yang baik
Hasyiem | = | Yang bermaruah
Hasyim | = | Pemurah, yang suka menjamu orang
Hasnain | = | Dua kebaikan
Hatadi | = | Keaslianku
Hatim | = | Pemutus, penentu
Hawwari | = | Penolong, bersih
Haiyan | = | Yang hidup
Hawwas | = | Yang bersemangat
Haziq | = | Cerdik, pandai
Hazim | = | Tegas, cermat, bijak
Hazmi | = | Ketegasanku
Hayyun | = | Hidup
Hazwan | = | Pemberianku
Hibatullah | = | Kurnia
Hidayat | = | Petunjuk
Hidawi | = | Pemberian
Hidayatullah | = | Petunjuk Allah
Hijazi | = | Kebersihanku
Hikmat | = | Hikmat
Hilal | = | Bulan sabit
Hilman | = | Kesopanan, kesabaran
Hilmi | = | Kesopananku, kesabaranku
Himmat | = | Cita-cita
Hisyam | = | Murah hati
Hisyamuddin | = | Kemurahan agama
Hiwayat | = | Yang disukai
Hubaib | = | Kekasih
Hulaif | = | Yang setia
Hulawi | = | Yang manis/menarik
Humaidi | = | Kepujianku
Humdi | = | Yang memuji
Husain | = | Elok, cantik
Husoin | = | Benteng pertahanan
Husaini | = | Kebaikanku
Husnayan | = | Kemenangan, syahid
Huzaifah | = | Nama sahabat nabi Muhammad SAW
Huzaiman | = | Nama sahabat nabi Muhammad SAW


- W - X - Y - Z -

Ibad | = | Yang rajin beribadah
Ibrahim | = | Nama nabi
Ibhar | = | (Lihat Bahar)
Ibtisam | = | Senyuman
Idlan | = | Keadilan
Idris | = | Nama nabi
Idrus | = | Singa
Iffat | = | Kehormatan diri
Idraki | = | Pengetahuanku, kefahamanku
Iftiqar | = | Keperluan
Ihsan | = | Kebaikan
Iftikhar | = | Kehormatan
Ihtisyam | = | Kehebatan
Ijlal | = | Penghormatan
Ikhwan | = | Persaudaraan
Ikhlas | = | Memuliakan
Ikram | = | Menghormati
Iktidal | = | Keadilan
Ikhtiari | = | Pilihanku
Iktisham | = | Tenaga
Ikhtiaruddin | = | Pilihan agama
Iktimad | = | Berserah
Ilyas | = | Nama nabi
Ilyasa | = | Nama nabi
Iliya | = | Nama nabi
Ilham | = | Ilham
Imadi | = | Sokonganku
Imaduddin | = | Tiang agama
Iman | = | Iman
Imdad | = | Tolong, bantu, sokong
Imtiyaz | = | Pilihan
Imran | = | Budi bahasa
Inayat | = | Pertolongan
Insaf | = | Kesedaran
Intisar | = | Kemenangan
Inas | = | Kelembutan
Iqtidar | = | Kekuatan, tenaga
Iqbal | = | Kejayaan
Irfan | = | Kebijaksanaan, kesyukuran
Irsyad | = | Nasihat, panduan
Irsyaduddin | = | Panduan agama
Is'ad | = | Beroleh taufiq
Ishak | = | Nama nabi
Iskandar | = | Nama seorang raja
Isma | = | Pemelihara
Isyhad | = | Penyaksian
Islam | = | Kesejahteraan
Islah | = | Pembetulan
Ismail | = | Nama nabi
Ismat | = | Ketulinan, kesucian
Isa | = | Nabi nabi
Israr | = | Persendirian
Israr | = | Persendirian
Isyraq | = | Memberi sinar
Istafa | = | Pilih, suka
Isyraf | = | Pengganti
Iwadh | = | Pengganti
Ithar | = | Mengasihi orang lain
Iyad | = | Sokongan, kekuatan
Izdiyad | = | Pertambahan
Izdihar | = | Perkembangan, kemajuan
Izz | = | Kekuatan
Izzan | = | Kepatuhan
Izzat | = | Kemuliaan
Izzuddin | = | Kemuliaan agama
Izzul Islam | = | Kemuliaan Islam


- W - X - Y - Z -

Abdul Alim | = | Hamba Allah Yang Mengetahui
Abdul Azim | = | Hamba Allah Yang Agung
Abdul Aziz | = | Hamba Allah Yang Mulia
Abdul Bari | = | Hamba Allah Yang Banyak Kebaikan
Abdul Basit | = | Hamba Allah Yang Melimpah Nikmat
Abdul Baqi | = | Hamba Allah Yang Kekal
Abdul Dayyan | = | Hamba Allah Yang Membalas
Abdul Jabbar | = | Hamba Allah Yang Tegas
Abdul Jalil | = | Hamba Allah Yang Mulia
Abdul Jawad | = | Hamba Allah Yang Pemurah
Abdul Fattah | = | Hamba Allah Yang Membuka
Abdul Ghafur | = | Hamba Allah Yang Membuka
Abdul Ghani | = | Hamba Allah Yang Pengampun
Abdul Hadi | = | Hamba Allah Yang Kaya
Abdul Hafiz | = | Hamba Allah Yang Memelihara
Abdul Haiy | = | Hamba Allah Yang Hidup
Abdul Hak | = | Hamba Allah Yang Sebenar
Abdul Hakam | = | Hamba Allah Yang Menghukum
Abdul Hakim | = | Hamba Allah Yang Bijaksana
Abdul Halim | = | Hamba Allah Yang Lemah Lembut
Abdul Hamid | = | Hamba Allah Yang Terpuji
Abdul Hanan | = | Hamba Allah Yang Penyayang
Abdul Ilah | = | Hamba Allah / hamba Tuhan
Abdul Karim | = | Hamba Allah Yang Pemurah
Abdul Khaliq | = | Hamba Allah Yang Mencipta
Abdullah | = | Hamba Allah
Abdul Latif | = | Hamba Allah Yang Lemah Lembut
Abdul Majid | = | Hamba Allah Yang Mulia
Abdul Mannan | = | Hamba Allah Yang Memberi Nikmat
Abdul Muhaimin | = | Hamba Allah Yang Berkuasa
Abdul Mu'ati | = | Hamba Allah Yang Memberi
Abdul Mun'im | = | Hamba Allah Yang Memberi Nikmat
Abdul Nasir | = | Hamba Allah Yang Menolong
Abdul Qadir | = | Hamba Allah Yang Berkuasa
Abdul Qahar | = | Hamba Allah Yang Perkasa
Abdul Qayyum | = | Hamba Allah Yang Berkuasa
Abdul Rauf | = | Hamba Allah Yang Pengasih
Abdul Rahman | = | Hamba Allah Yang Pemurah
Abdul Rahim | = | Hamba Allah Yang Penyayang
Abdul Rasyid | = | Hamba Allah Yang Bijaksana
Abdul Razak | = | Hamba Allah Yang Memberi Rezeki
Abdul Syakur | = | Hamba Allah Yang Bersyukur
Abdul Samad | = | Hamba Allah Yang Menjadi Tumpuan
Abdul Salam | = | Hamba Allah Yang penyelamat
Abdul Wafi | = | Hamba Allah Yang Setia
Abdul Wadud | = | Hamba Allah Yang Pengasih
Abdul Wahab | = | Hamba Allah Yang Memberi
Abdul Warith | = | Hamba Allah Yang Mewarisi
Abdul Wahid | = | Hamba Allah Yang Esa
Abbasy | = | Rajin berusaha
Abadi | = | Yang Kekal
Abbas | = | Nama sahabat Nabi Muhammad SAW Muhammad SAW
Abrisam | = | Yang lembut/tampan
Abhar | = | Yang bergemerlapan/Yang berseri
Absyar | = | Bergembira
Abid | = | Yang beribadat
Abidin | = | Yang beribadat
Abu Bakar | = | Nama sahabat Nabi Muhammad SAW (Yang bersegera)
Abu Zar | = | Nama sahabat Nabi Muhammad SAW
Abu Samah | = | Pemaaf, Yang bertoleransi
Abu Wasim | = | Yang tampan.
Adabi | = | Kesopananku, kesusasteraan
Adlan | = | Keadilan
Adam | = | Nama Nabi, ikutan, teladan
Adham | = | Yang cantik
Adil | = | Yang adil
Adli | = | Keadilanku, kelurusanku
Adnan | = | Nama datuk Nabi
Adi | = | Nama sahabat Nabi Muhammad SAW
Adib | = | Pujangga
Adwa' | = | Cahaya
Affan | = | Pendaki
Affandi | = | Gelaran bagi orang yang berkedudukan
Afiq | = | Yang mulia
Afif | = | Yang bermaruah
Afnan | = | Kecantikan/seri
Aflah | = | Yang beruntung
Afqar | = | Fakir
Afham | = | Yang pandai
Afsar | = | Lebih Jelas
Afdhal | = | Terbaik
Afkar | = | Yang bijak
Afwu | = | Pemaaf
Agha | = | Ketua, pimpinan
Aghna | = | Berdikari
Ahlan | = | Keselamatan
Ahlam | = | Impian, kesabaran
Ahda | = | Beroleh petunjuk
Ahlami | = | Impianku, kelembutanku
Ahna | = | Yang lemah lembut
Ahmas | = | Yang bersemangat
Ahnaf | = | Yang berpegang teguh pada ajaran agama
Ahwaz | = | Yang bersungguh-sungguh
Ahsan | = | Yang terbaik
Ahza | = | Yang beruntung
Ahmad | = | Yang terpuji
Ahwas | = | Pemberani
Aibaq | = | Pesuruh
Aiyub | = | Nama nabi
aiman | = | Yang bertuah
Aisar | = | Yang senang, mudah
Aisy | = | Mewah, kaya raya
Ajad | = | Berbuat baik
Ajmal | = | Cantik, molek
Ajwad | = | Yang lebih pemurah
Akalil | = | Mahkota
Akramah | = | Nama sahabat Nabi Muhammad SAW
Akbar | = | Yang besar
Akram | = | Yang mulia
Akhtar | = | Yang terpilih
Akma | = | Pimpinan
Akid | = | Yang kuat, teguh, tetap
Akif | = | Yang menumpukan dirinya pada sesuatu
Akmal | = | Sempurna, sangat pandai
Aqhar | = | Yang gagah
Akwa | = | Yang perkasa, kuat
Alwan | = | Warna-warni
Alma' | = | Yang bergemerlapan
Alamgir | = | Penakluk dunia
Alim | = | Yang mengetahui
Alauddin | = | Ketinggian agama
Allamah | = | Yang berilmu luas
Ali | = | Yang mulia, yang tinggi kedudukannya
Aliyan | = | Yang tinggi
Alif | = | Kawan rapat
Alham | = | Beroleh ilham
Alim | = | Mengetahui
Aliuddin | = | Ketinggian agama
Alzam | = | Yang tekun
Altaf | = | Baik hati,lemah lembut
Altamis | = | Panglima, ketua
Amadi | = | Masa, matlamatku
Amad | = | Tujuan
Amal | = | Cita-cita, harapan
Amili | = | Yang bekerja
Amali | = | Cita-citaku, harapanku
Amaluddin | = | Cita-cita agama
Aman | = | Sentosa, keamanan
Amanat | = | Pertaruhan, amanh
Amar | = | Yang ramai zuriat
Amjad | = | Mulia, soleh
Amin | = | Yang amanah, yang dipercayai
Aminin | = | Orang-orang yang aman
Aminuddin | = | Pengamanah agama
Amnan | = | Tempat yang aman
Amir | = | Putera, ketua, pemerintah
Amiruddin | = | Pembela agama
Ammar | = | Yang memakmurkan, yang kuat iman
Amami | = | Golonganku
Amnan | = | Ketenangan
Amni | = | Keamananku
Amani | = | Kesejahteraanku
Amsyar | = | Yang cergas
Amzar | = | Yang mulia
Amran | = | Yang memakmurkan
Amrin | = | Perintah
Amrun | = | Kemakmuranku
Amkrun | = | Orang-orang berkuasa
Anas | = | Kemesraan, cinta, kasih
Anaqi | = | Keindahanku yang menawan hati
An'am | = | Yang diberi nikmat
Anma | = | Yang maju
Aniq | = | Yang kacak lagi menawan hati
Anmar | = | Air yang bersih
Anis | = | Yang mesra, teman setia
Andar | = | Yang berseri
Ansar | = | Penolong, penyokong
Ansari | = | Penolongku, penyokongku
Anwar | = | Yang bercahaya
Anwari | = | Cahayaku
Aqil | = | Bijak, terpelajar
Aqlan | = | Kebijakan
Aqmar | = | Putih, cantik
Aqra | = | Pandai membaca
Arafat | = | Yang terkenal, kenalan
Arami | = | Panji-panji
Arib | = | Yang mahir
Arham | = | Yang mesra
Arif | = | Yang bijak, yang mengetahui
Ariffin | = | Yang bijak
Arfan | = | Mengetahui
Arman | = | Harapan, aspirasi
Arqam | = | Nama sahabat Nabi Muhammad SAW
Arfa | = | Yang tinggi, mulia
Arsalan | = | Singa
Arsyad | = | Yang sangat cerdik
Arumi | = | Asal keturunanku
Asad | = | singa
As'ad | = | Yang berbahagia
Asdaq | = | Benar
Asjad | = | Emas, permata
Asil | = | Yang mulia
Asyiq | = | Kekasih, pencinta
Askari | = | Tentera
Aslam | = | Selamat, terkawal
Asfa | = | Yang suci
Aslah | = | Yang lebih baik
Asmah | = | Yang pemaaf
Asmai | = | Hati yang suci
Asmaan | = | Hati yang suci dan pendapat yang teguh
Asmar | = | Yang hitam manis
Ashmah | = | Yang berani
Asna | = | Yang tinggi, yang bersinar
Asnawi | = | Yang berseri, gemilang
Asri | = | Masaku, kemajuanku mengikut masa
Asytar | = | Yang menawan
Asyari | = | Perasaanku
Asyraaf | = | Yang mulia
Asy'ar | = | Perasa, jiwa halus
Asyrani | = | Periang, kemegahanku
Asymawi | = | Pemberianku
Ata | = | Pemberian
Ataullah | = | Kurniaan Allah
Atyab | = | Wangi
Atif | = | Belas Kasihan
Athar | = | Suci, bersih
Athari | = | Yang bersih
Athmar | = | Yang berjaya
Atmam | = | Kesempurnaan
Aus | = | Pemberian
Aufa | = | Yang setia
Aun | = | Bantuan, pertolongan
Auni | = | Ketetapanku
Awsam | = | Yang segak
Awam | = | Yang tangkas
Awraq | = | Yang memberi semangat
Awad | = | Gantian, pemberian
Awwal | = | Pandai mentakwil
Awwam | = | Perenang
Awuf | = | Yang wangi
Awadullah | = | Pemberian, gantian dari Allah
Awliya | = | Kekasih
Awwab | = | Yang banyak bertaubat
Awali | = | Pedang
Awwadi | = | Yang bersungguh-sungguh
Ayadi | = | Nikmat
Aysar | = | Yang mudah
Ayyub | = | Nama nabi
Azad | = | Bebas, merdeka
Azfar | = | Yang berjaya, yang menang
Azka | = | Semakin maju
Azhar | = | Yang berseri, yang gemilang
Azam | = | Keazaman
Azaim | = | Pelbagai azam
Azim | = | Besar
Azman | = | Cita-cita, tekad
Azmi | = | Cita-citaku, tekadku
Azmil | = | Kawan rapat
Aziman | = | Keazaman
Azamuddin | = | Keazaman agama
Azhari | = | Yang berseri, yang gemilang
Azhad | = | Yang zuhud, warak
Azizan | = | Yang mulia, yang kuat, kekasih
Azib | = | Sabar dan gigih
Aziz | = | Yang mulia, yang kuat, kekasih
Azizi | = | Kesayanganku, kekasihku
Azbin | = | Bersih, suci
Azri | = | Kekuatanku, penyokongku
Azwar | = | Rajin ziarah/emas


- W - X - Y - Z -

Jaafar | = | Anak sungai
Jaballah | = | Hadiah Allah
Jabir | = | Yang melegakan
Jabil | = | Yang kreatif
Jabrullah | = | Pertolongan Allah
Jabran | = | Pengganti, pembetul
Jabri | = | Pertolongnaku
Jadid | = | Yang baru
Jadir | = | Pemurah
Jadulhaq | = | Jalan kebenaran
Jaffan | = | Yang terkawal
Jafni | = | Kawalanku dari kejahatan
Jafin | = | Yang mengawal
Jahid | = | Yang berusaha
Jahdi | = | Kemampuan
Jahran | = | Yang tangkas
Jalal | = | Kemulian, keagungan
Jali | = | Yang nyata
Jalaluddin | = | Kemulian agama
Jalil | = | Yang mulia
Jalud | = | Kuat dan sabar
Jamal | = | Kecantikan
Jamali | = | Kecantikanku
Jamaluddin | = | Keindahan agama
Jamalullail | = | Keindahan malam
Jam'an | = | Kesatuan
Jamil | = | Yang tampan
Jarir | = | Tempat bertumpu
Jaris | = | Kurnian Allah
Jamri | = | Perhimpunanku
Jamsyir | = | Kecantikan
Jauhar | = | Permata
Jauhari | = | Permataku
Jauni | = | Keputihan, siang
Jauzan | = | Pertengahan
Jawad | = | Murah hati
Jawahir | = | Permata
Jazali | = | Kegembiraanku
Jazil | = | Besar, banyak
Jazim | = | Mempastikan
Jazli | = | Fasih
Jazman | = | Tekad bulat
Jazmi | = | Tekad yang kukuh
Jazlan | = | Gembira, riang
Jazman | = | Tekad yang kukuh
Jazuli | = | Nisbah
Jihadi | = | Perjuangan
Jilani | = | Penyiaranku
Jiwari | = | Jaminanku
Jiratullah | = | Bantuan Allah
Jubair | = | Pertolongan
Juani | = | Sinaranku
Jufri | = | Keluasan, di tengah
Juhlan | = | Yang termulia
Juman | = | Mutiara
Jumani | = | Mutiaraku
Junaid | = | Tentera
Junaidi | = | Tenteraku
Junaidun | = | Tentera
Juwaidi | = | Keelokanku


- W - X - Y - Z -

Kaab | = | Kemuliaan
Kabir | = | Agung, besar
Kailani | = | Nisbah
Kafil | = | Penjamin
Kalim | = | Pemidato
kamal | = | Kesempurnaan
kamaluddin | = | Kesempurnaan agama
Kamaruzzaman | = | Bulan masa
Kamaruddin | = | Bulan agama
Kamarul Arifin | = | Bulan orang arif
Kamil | = | Sempurna
Karami | = | Kemuliaanku
Karim | = | Yang mulia
Karman | = | Kemuliaan
Kasir | = | Melimpah, banyak
Katib | = | Juru tulis
Kazim | = | Penyabar
Khair | = | Kebaikan
Khaizuran | = | Ketua, pemimpin
Khairuddin | = | Kebaikan agama
Khan | = | Ketua, pemimpin
Khadim | = | Sukarelawan
Khalifah | = | Pengganti, wakil
Khalid (Abd) | = | Yang kekal
Khaldun | = | Kekal
Khalis | = | Suci, ikhlas
Kariman | = | Haji dan jihad
Khattab | = | Pengkhutbah
Khatib | = | Petah berpidato
Khayam | = | Pembuat khemah
Khazin | = | Bendahari
Khazindar | = | Penjaga kekayaan
Khilfi | = | Pengganti
Khidir | = | Nama nabi
Khumaini | = | Pandangan yang jauh
Khuwailid | = | kekal
Khuararizmi | = | Nisbah
Khudari | = | Nisbah
Khabir | = | Pakar, berpengalaman
Khursyid | = | Matahari
Khairan | = | Kebaikan
Khairin | = | Kebaikan
Khairani | = | Kebaikanku
Khairul Anwar | = | Cahaya yang baik
Khairuddin | = | Sebaik-baik agama
Khairul Anam | = | Sebaik-baik manusia
Khairun Nas | = | Sebaik-baik manusia
Khairul Zaman | = | Sebaik-baik masa
Khairul Amirin | = | Sebaik-baik pembina
Khairul Harisin | = | Sebaik-baik pengawal
Khairul Ikhwan | = | Persaudaraan yang baik
Khalas | = | Yang selamat
Khallad | = | Yang kekal
Khalil | = | Sahabat
Khuwailid | = | Yang kekal
Khalili | = | Sahabat
Kiram | = | Mulia
Kiraman | = | Mulia


- W - X - Y - Z -

Labib | = | Cerdik, munasabah
Labid | = | Nama sahabat nabi Muhammad SAW
Lamani | = | Kegemilanganku
Lamin | = | Kepercayaan
Latif | = | Lembut, bersopan
Lazim | = | Tetap
Lazman | = | Tetap
Lais | = | Berani
Lujaini | = | Keputihan, perak
Liaqat | = | Kebolehan, keupayaan
Liwaun Nasari | = | Panji kemenangan
Liwauddin | = | Panji agama
Lutfi | = | Kehalusanku
Lizam | = | Yang mendiami
Lubaid | = | Yang kaya
Lukman | = | Nama nabi, bijaksana
Lubawi | = | Yang pintar
Lut | = | Nama nabi
Luzman | = | Tetap
Lutfan | = | Lemah lembut
Lutfilah | = | Taufik Allah
Lutfir Rahman | = | Pertolongan Allah
Lutfil Hadi | = | Taufik Allah Yang Hadi


- W - X - Y - Z -

Maamar | = | Kemakmuran
Maarif | = | Kecantikan, pengetahuan
Mabruk | = | Yang diberkati
Maasyir | = | Pandai bergaul
Mabrur | = | Membuat kebajikan
Majad | = | Kemuliaan
Makmun | = | Beramanah
Mahasin | = | Kebaikan
Majid | = | Dihormati
Majdi | = | Kemulianku
Mahamid | = | Pujian, terpuji
Mahdi | = | Yang mendapat hidayah
Mahbub | = | Yang dikasihi
Mahadhir | = | Menulis kebaikan
Mahfuz | = | Terpelihara
Madani | = | Kemajuan
Makhluf | = | Maju ke hadapan
Mahmud | = | Terpuji
Makhlad | = | Yang kekal
Mahzuz | = | Bernasib baik
Maisur | = | Yang senang
Makarim | = | Kemulian
Mahran | = | Kebijaksanaan
Malazi | = | Tempat perlindungan
Mamduh | = | Terpuji
Mahir | = | Pakar
Manaf | = | Ketinggian, kenaikan
Manan | = | Pemurah
Mansur | = | Pemenang
Manzur | = | Yang boleh diterima, dipersetujui
Maqbul | = | Diterima, dipersetujui
Marjan | = | Batu karang
Marzuq | = | Yang mendapat rezeki
Marzuqi | = | Rezekiku
Marwan | = | Bermaruah
Masrur | = | Yang riang, suka
Masykur | = | Yang bersyukur
Mas'ud | = | Bertuah
Masyhad | = | kesaksian
Masyahadi | = | Persaksianku, tuntutanku
Masyruh | = | Lapang dada
Masun | = | Yang terpelihara
Matlub | = | Cita-cita
Maula | = | Tuan besar
Maulawi | = | Yang berzuhud (Maulana)
Mawardi | = | Nisbah, air mawarku
Mazhud | = | Yang zuhud
Maziz | = | Mulia
Mikyad | = | Yang bertaubat
Miftah | = | Pembuka, perintis
Mirza | = | Anak yang baik
Minhaj | = | Acara, biasa
Mikbad | = | Ibadah
Mifzal | = | Teramat mulia
Mikdam | = | Berani
Misbah | = | Pelita, cahaya
Mizwar | = | Rajin berkunjung
Muammar | = | Panjang umur
Muawiyah | = | Nama sahabat nabi Muhammad SAW
Muaz | = | Nama sahabat nabi Muhammad SAW
Muayyad | = | Kuat, menang
Muazzam | = | Dihormati, disanjungi
Mubarak | = | Yang diberkati
mubin | = | Lut sinar, jernih
Mubasyir | = | Pembawa petanda yang baik
Mughis | = | Penolong
Muhaimin | = | Yang memelihara dan mengawal
Muqtadir | = | Yang berkemampuan
Muhammad | = | Yang terpuji, di rahmati
Muharram | = | Bulan Muharram
Muhazzab | = | terdidik
Muhajir | = | Yang berhijrah
Muhsin | = | Yang membuat kebaikan
Muhib | = | Kekasih, peminat
Muqri | = | Ahli ibadat
Muhibbuddin | = | Pengasih agama
Muhtadi | = | Beroleh hidayah
Mujahid | = | Pejuang Islam
Mujib | = | Penyahut
Mujibuddin | = | Penyahut agama
Mujibur | = | Penyahut seruan Allah Yang Maha Pengasih
Mulhim | = | Pemberi inspirasi
Muinuddin | = | Pembela agama
Muntasir | = | Yang menang
Muizzuddin | = | Penyokong agama
Muktasim | = | Terjaga
Mukhtar | = | Yang terpilih
Mukti | = | Pemberani
Munawwar | = | Berkilau
Munawwir | = | Bersinar
Munir | = | Yang menerangi
Munabbih | = | Pemberi peringatan
Munzir | = | Yang memberi amaran
Muntazar | = | Yang diawasi
Murad | = | Keinginan, cita
Mursyid | = | Pemimbing, guru
Mursil | = | Wakil
Muradi | = | Harapanku
Mus'ab | = | Nama sahabat nabi Muhammad SAW
Musa | = | Nama nabi
Mus'ad | = | Yang bahagia
Musaid | = | Penolong
Musawi | = | Yang adil
Muslih | = | Yang membaiki
Muslihin | = | Yang memulihkan
Muslihuddin | = | Pemulih agama
Muslim | = | Yang menyerah diri kepada Allah
Musayyad | = | Nama sahabat nabi Muhammad SAW
Mustafa | = | Yang terpilih
Mustaqim | = | Yang lurus
Musyrif | = | Tinggi, pengawas
Mutalib | = | Yang menuntut dari masa ke semasa
Muzaffar | = | Kemenangan


- W - X - Y - Z -

Nabil | = | Yang cerdik, mulia
Nabhan | = | Perwira, berwaspada
Nabihan | = | Mulia, masyhur
Nadir | = | Berseri-seri
Nadim | = | Rakan, sahabat
Nafis | = | Bernilai
Nahdan | = | Kebangkitan
Nahar | = | Keluasan sungai
Nahlan | = | Berbisa
Naif | = | Tinggi
Najwan | = | kemenangan
Naim | = | Kesenangan
Najmuddin | = | Bintang agama
Najah | = | Kemenangan
Najib | = | Keturunan yang mulia
Najih | = | Yang menang
Najid | = | Gagah, berani
Najdat | = | Berani
Najmi | = | Bintangku
Nafiz | = | Yang melaksanakan
Nafi' | = | Yang berguna
Najmussabah | = | Bintang subuh
Naqib | = | Yang menjamin
Naqiuddin | = | Kebersihan agama
Nasab | = | Keturunan mulia
Nasih | = | Pemberi nasihat
Nasim | = | Angin sepoi-sepoi bahasa
Nasr | = | Pertolongan
Nasir | = | Pertolongan
Nasran | = | Pertolongan
Nasiruddin | = | Pembela agama
Nasri | = | Pertolonganku
Nasrat | = | Kemenangan
Nasruddin | = | Pertolongan Allah
Nasrullah | = | Pertolongan Allah
Nasrul Haq | = | Pertolongan kebenaran
Nasif | = | Yang insaf
Nasyat | = | Kecergasan
Naufal | = | Dermawan
Nawaf | = | Tinggi
Nawi | = | Ketua
Nawab | = | Pemimpin, pemerintah
Nazhan | = | Jauh dari yang dieji
Nazim | = | Penyajak
Nazmi | = | Bintangku, keindahanku
Nazri | = | Pandanku
Nazran | = | Persembahan untuk Allah
Nazir | = | Bandingan
Nazih | = | Yang bersih
Nikmat | = | Rahmat
Nidal | = | Perjuangan, menang
Nizam | = | Peraturan
Nizar | = | Yang memerintah
Niamuddin | = | Peraturan agama
Niyaz | = | Doa, harapan
Nuh | = | Nama nabi
Nu'man | = | Kebaikan
Nuaim | = | Nikmat
Nufail | = | Pemberian, hadiah
Nuri | = | Cahayaku
Nurhan | = | Cahaya raja
Nuruddin | = | Cahaya agama
Nurul Haq | = | Cahaya kebenaran
Nurul Hidayah | = | Cahaya petunjuk
Nusari | = | Pertolongan
Nurul Islam | = | Cahaya Islam
Nuwair | = | Cahaya


- W - X - Y - Z -

Qabbab | = | Singa
Qabus | = | kacak
Qaddas | = | Suci
Qadus | = | Yang lapang hati
Qadir | = | Berkuasa
Qadri | = | Kemampuanku
Qahir | = | Yang menang
Qaid | = | Ketua, pemimpin
Qamar | = | Bulan
Qamaruddin | = | Bulan agama
Qamarul Islam | = | Bulan Islam
Qamaruzzaman | = | Bulan masa
Qasid | = | Yang menentu
Qarin | = | Pendamping
Qatadah | = | Nama sahabat nabi Muhammad SAW
Qawiem | = | Yang lurus
Qawi | = | Gagah, berkuasa
Qayyim | = | Ketua
Qayyum | = | Abadi, kekal
Qinawi | = | Redha dan rela
Qiwamuddin | = | Asas agama
Qudrat | = | Kemampuan
Qusyairi | = | Hujan
Qudwah | = | Teladan, ikutan
Qutaibah | = | Nama tabi'ie
Qutub | = | Ketua, bintang, asas
Qutubuddin | = | Asas agama, bintang agama
Qutubul Islam | = | Asas Islam
Quwaidir | = | Yang berkemampuan


- W - X - Y - Z -

Rafaat | = | Sangat lembut, cinta
Rabbani | = | Arif dan soleh
Rabah | = | Usaha, keuntungan
Rabiti | = | Yang zahid
Ra idi | = | Pelopor
Radi | = | Yang redha
Rafi | = | Yang meninggikan
Rafidan | = | Sungai Dajlah dan Furat
Rafid | = | Pembantu, pemberi
Rafie | = | Tinggi dan mulia
Rafiq | = | Pendamping
Rafiqi | = | Pendampingku
Rafiqin | = | Pendamping
Rafiuddin | = | Pendukung agama
Raghib | = | Yang menyukai
Rahimi | = | Kesayangaku
Rahmani | = | Kesayanganku
Rahmuni | = | Yang penyayang
Rahmat | = | Rahmat, belas kasihan
Raid | = | Perintis, ketua
Raimi | = | Keutamaanku
Raif | = | Pengasih
Rais | = | Ketua
Raiyan | = | Yang puas
Rajab | = | Bulan Rejab
Rajauddin | = | Harapan agama
Rajaie | = | Harapanku
Rakin | = | Dihormati
Ramadhan | = | Bulan Ramadhan
Ramli | = | Penelitianku
Raihan | = | Wangi, harum
Ramzi | = | Lambangku
Rasin | = | Yang mantap
Rasmi | = | Yang rasmi, lukisanku
Rasuli | = | Wakilku, utusanku
Rasyad | = | Memperolehi petunjuk
Rasydan | = | Mendapat petunjuk
Rasyid | = | Petunjuk, cerdas
Rauf | = | Pengasuh
Rawi | = | Tubuh serta akal yang sihat
Raqib | = | Penjaga, pengawal
Rawiyani | = | Keindahanku
Razi | = | Nisbah
Razin | = | Yang berakhlak
Raziq (Abd) | = | Hamba yang murah rezeki
Riyad | = | Taman
Rida | = | Keredhaan
Ridauddin | = | Keredhaan agama
Ridwan | = | Keredhaan
Riffat | = | Pangkat yang tinggi
Rifai | = | Yang tinggi dan mulia
Rif'at | = | Ketinggian
Rifqi | = | Lemah lembut
Ruknuddin | = | Sendi agama
Riman | = | Kijang
Ruslan | = | Wakil, penyampai
Rusli | = | Wakilku
Rustam | = | Berani, kuat
Rusydi | = | Kecerdikanku
Rusyaidi | = | Yang cerdik
Rusydan | = | Petunjuk
Rusyduddin | = | Kelurusan agama
Ruwaidi | = | Angin sepoi-sepoi
Ruzain | = | Tempat ketenteramanku


- W - X - Y - Z -

Saadan | = | Kebahagian
Saad | = | Bahagia
Saaduddin | = | Agama yang membahagiakan
Saadi | = | Kebahagianku
Sa'dun | = | Kebahagian
Sabahi | = | Ketua pejuang
Sabiq | = | Yang mendahului
Sabil | = | Jalan
Sabit | = | Yang baik, pemurah
Sabir | = | Yang sabar
Sabqi | = | Keutamaanku
Sabran | = | Kesabaran
Sabri | = | Kesabaranku
Sadad | = | Kejujuranku
Sadat | = | Pimpinan
Sadiq | = | Yang benar
Sadruddin | = | Pemimpin agama
Safaraz | = | Dihormati
Safiy | = | Yang bersih dan jujur
Safiuddin | = | Kesucian agama
Safir | = | Wakil, duta besar
Safwan | = | Bersih, ikhlas
Saghir | = | Yang mengikut
Sahil | = | Mudah, senang
Sahlan | = | Mudah, senang
Sahnon | = | Kehalusan
Sahli | = | Kemudahanku
Sajid | = | Orang yang sujud
Said | = | Yang bahagia
Saidun | = | Yang berbahagia
Saifuddin | = | Pedang agama
Saiful Islam | = | Pedang Islam
Saifullah | = | Pedang Allah
Sakhawi | = | Kemurahan hati
Salahuddin | = | Kebaikan agama
Salam | = | Kesejahteraan
Samran | = | Pertolongan
Sama'an | = | Yang patuh
Salamat | = | Kesejahteraan
Soleh | = | Yang baik
Solihin | = | Yang baik
Solihan | = | Yang baik
Salim | = | Selamat, terkawal
Saliman | = | Kesejahteraan
Salman | = | Selamat, terkawal
Sarhan | = | Kemudahan
Samad | = | Serba baik
Samih | = | Pemaaf, pemurah
Samir | = | Penghibur
Sattar | = | Menutup cela, aib
Subhi | = | Subuh
Sufyan | = | Nama sahabat nabi Muhammad SAW
Suhaib | = | Kemerah-merahan
Suhail | = | Senang, mudah
Suhaili | = | Kemudahanku
Sulaim | = | Sejahtera
Sulaiman | = | Nama nabi, sejahtera
Sulhidar | = | Bersenjata
Sulaimi | = | Kesejahteraanku
Sulwan | = | Kepuasan
Suwadi | = | Rahsiaku
Sya'ban | = | Bulan Sya'ban
Sya'rani | = | Nisbah
Suhaid | = | Lembut, tampan
Syabil | = | Bintang
Syaddad | = | Yang perkasa
Syukri | = | Kesyukuran
Syafaat | = | Pembelaan, pertolongan
Saud | = | Yang bahagia
Siddiq | = | Yang membenarkan
Sidqi | = | Kebenaranku
Silmi | = | Kedamaianku
Sinwan | = | Kembar
Siraj | = | Pelita
Sirajuddin | = | Pelita agama
Sirhan | = | Berani, singa
Sirin | = | Nama seorang tabi'ie
Sufi | = | Ahli tasauf
Syafi | = | Yang menyembuhkan
Syafiq | = | Penyayang
Syahmi | = | Mulia, berani, bijak
Syahir | = | Terkenal
Syahiran | = | Terkenal
Syahin | = | Tiang neraca
Syakir | = | Pengenang budi
Syamini | = | Keharuman yang tinggi
Sam'un | = | Pendengaran
Syukran | = | Kesyukuran
Sanad | = | Tempat bergantung
Sanim | = | Yang darjatnya tinggi
Syamsul Bahri | = | Matahari lautan
Syamsuddin | = | Matahari agama
Syamsuz Zaman | = | Matahari masa
Syamsi | = | Matahariku
Syamsir | = | Pedang
Syaraf | = | Kemuliaan
Syarafat | = | Harga diri, maruah
Syarifuddin | = | Kemuliaan agama
Syarif | = | Dipuji, mulia
Syarafuddin | = | Yang mulia agamanya
Syaukat | = | Kekuasaan
Syahabuddin | = | Bintang agama
Syawal | = | Bulan syawal
Syazani | = | Kecergasanku
Syazwan | = | Haruman kasturi
Syazwi | = | Keharumanku
Syubli | = | anak singa
Syihabuddin | = | Bintang agama
Syuaib | = | Nama nabi
Syu'bah | = | Nama sahabat nabi Muhammad SAW
Syukur | = | Kesyukuran
Syukri | = | Kesyukuran
Syuwari | = | Kecantikanku


- W - X - Y - Z -

Tabari | = | Nama ulama
Tabrani | = | Nama ulama
Taha | = | Nama nabi
Tahir | = | Yang bersih dan murni
Tahsin | = | Menghiasi
Tahfiz | = | Usaha menghafaz
Taib | = | Yang baik
Tajuddin | = | Mahkota agama
Tadwin | = | Pencatatan
Tafhim | = | Usaha memahami
Tahzir | = | Usaha memberi peringatan
Tajuzzaman | = | Mahkota masa
Taisir | = | Memudahkan
Tal'at | = | Ketinggian
Talal | = | Keindahan
Talhah | = | Nama sahabat nabi Muhammad SAW
Talib | = | Penuntut
Tal'ah | = | Tampil, maju
Tamam | = | Kesempurnaan
Tamim | = | Kejadian sempurna
Tamrin | = | latihan, pembiasaan
Tamamul Qamar | = | Bulan purnama
Taqiuddin | = | Bertaqwa untuk agama
Tariq | = | Bintang subuh
Tarif | = | Istimewa
Taqris | = | Berperisa
Tqsnif | = | Mengarang
Tasnim | = | Air terjun dalam syurga
Taufiq | = | Pertolongan, petunjuk
Taufiqillah | = | Petunjuk Allah
Tauqan | = | Kemampuan hati
Tawadu | = | Merendah hati
Tijani | = | Mahkota
Thabit | = | Yang tabah
Thamir | = | Berjaya, berbuah
Tharwan | = | kekayaan
Thamin | = | Yang tinggi nilainya
Thaqif | = | Bijak dan cepat faham
Thauri | = | Revolusi
Tharwat | = | kekayaan
Thubat | = | Pahlawan
Tufail | = | Pengantara, gaya yang menarik


- W - X - Y - Z -

Ubbad | = | Banyak ibadat
Ubaid | = | Hamba, sahabat nabi Muhammad SAW
Ubaidan | = | Penyembahan
Ubaidullah | = | Hamba Allah
Ubadah | = | Sahabat nabi Muhammad SAW
Ukasyah | = | Sahabat nabi Muhammad SAW, labah-labah
Ukail | = | Pintar, pandai
Umair | = | Maju
Umar | = | Yang memakmurkan
Ulwan | = | Ketinggian, jelas
Urwah | = | Singa
Umaiyah | = | Sahabat nabi Muhammad SAW
Usaimin | = | Dari Uthman
Usaid | = | Berani, singa
Usyair | = | Kawan, suami
Uthman | = | Rajin dan gigih
Utbah | = | Nama sahabat nabi Muhammad SAW
Umran | = | Kemakmuran
Utaibah |  | Persimpangan lembah
Uwais |  | Pemberian
Uzair |  | Nama sahabat nabi Muhammad SAW
Uzzam | = | Singa


- W - X - Y - Z -

Waazin | = | Pengajaran
Wa'adi | = | Janjiku
Wabil | = | Pemurah
Wadud | = | Penyayang
Wadihan | = | Cantik, lawa
Wadi | = | Aman, tenteram
Wafid | = | Tamu
Wafiy | = | Setia, jujur
Wafiuddin | = | Setia pada agama
Wafri | = | Kekayaanku, keluasanku
Wafiq | = | Berjaya
Wahib | = | Pemberi
Wahab | = | Pemberian
Wahid | = | Tunggal
Wahiduddin | = | Terulung pada agamanya
Wahiduz Zaman | = | Terulung pada zamannya
Wahnan | = | Mudah, senang
Wail | = | Perteduhan, perlindungan
Waiz | = | Penasihat, mubaligh
Wajdi | = | Kesayanganku
Wajihuddin | = | Yang terkemuka dalam agama
Wali | = | Kekasih, pelindung
Walid | = | Kelahiran, yang dilahirkan
Waliuddin | = | Pembela dan pemelihara agama
Waqar | = | Ketenangan dan sopan santun
Waqur | = | Ketenangan dan kesopanan
Waqqas | = | Nama sahabat nabi Muhammad SAW
Waqiuddin | = | Pemelihara agama
Wardi | = | Bunga mawarku
Warid | = | Berani
Waris | = | Pewaris
Wasim | = | Segak, kacak
Wasil | = | Penghubung silatur rahim
Wazif | = | Yang tekun, gigih
Wathiq | = | Yang berkeyakinan
Wazien | = | Pendapat yang kukuh
Wazni | = | Yang menimbang secara adil
Waldan | = | Anak baik
Wazir | = | Menteri, yang berkuasa
Widad | = | Cinta, cita-cita
Wijdan | = | aSnubari, hati
Wisam | = | Petanda


- W - X - Y - Z -

Yaala | = | Kemuliaan, tinggi
Yaaqub | = | Nama nabi
Yaarub | = | Mahir bahasa arab
Yafiq | = | Mulia, dihormati
Yahya | = | Nama nabi, yang hidup
Yamin | = | Yang berkat
Yakut | = | Permata
Yaslam | = | Yang selamat, berserah
Yatim | = | Yang sangat berharga, tiadak bandingannya
Yasir | = | Yang senang
Yassaar | = | Kekayaan, kemewahan
Yaqzan | = | Yang berwaspada
Yaqin | = | Penuh keyakinan
Yasin | = | Nama nabi
Yawar | = | Pengawal peribadi
Yazdan | = | Belas kasihan
Yazid | = | Berkat
Yunan | = | Nama ulama
Yunus | = | Nama nabi
Yusuf | = | Nama nabi
Yusri | = | Kesenanganku


- W - X - Y - Z -

Zaalan | = | Rajin, giat
Zaafarani | = | Harum, wangi
Zabdan | = | Pemberian
Zabad | = | Keharuman kasturi
Zabadi | = | Keharumanku
Zabidi | = | Yang memberi
Zabir | = | Pintar, kuat
Zabran | = | Kuat, mampu
Zahab | = | Emas
Zahabi | = | Keemasan
Zahar | = | Sangat bergemerlapan
Zahid | = | Yang menjauhkan diri dari kemewahan
Zahidi | = | Yang menjauhkan diri dari kemewahan
Zahi | = | Yang cantik, berseri
Zahir | = | Yang cantik, berseri
Zahiruddin | = | Pembela agama
Zahirul Haq | = | Pendukung Hak
Zahil | = | Yang tenang
Zahin | = | Yang cerdik
Zahwan | = | Sedap dipandang
Zafar | = | Kemenangan/kejayaan
Zafir | = | Yang berjasa
Zafran | = | Kejayaan
Zafri | = | Kemenanganku
Zahran | = | Yang cantik, berseri
Zaid | = | Pertambahan, kelebihan
Zaidan | = | Pertambahan, kelebihan
Zaidun | = | Pertambahan, kelebihan
Zaidi | = | Pertambahanku, kelebihanku
Zaiyani | = | Hiasanku
Zaim | = | Pemimpin
Zain | = | Perhiasan
Zaini | = | Perhiasanku
Zakaria | = | Nama nabi
Zaki | = | Yang cerdik, yang harum, yang suci
Zakir | = | Yang mengenang, yang berzikir
Zakur | = | Yang kuat ingatan
Zakwan | = | Yang cerdik, yang harum
Zainuddin | = | Perhiasan agama
Zainul Abidin | = | Perhiasan orang beribadat
Zainul Ariffin | = | Perhiasan orang arif
Zainun | = | Perhiasan
Zamil | = | Teman, kawan
Zamir | = | Suara hati
Zamri | = | Kecantikanku
Zaman | = | Nasib
Zamanat | = | Yang dijamin
Zamzam | = | Air zamzam
Zar'ah | = | Tanaman
Zarif | = | Periang, berjenaka
Zawawi | = | Himpunan kebaikan
Zawwar | = | Banyak ziarah
Zawir | = | Ketua, pemimpin
Zayan | = | Yang cantik
Zayani | = | Kecantikanku
Zayyad | = | Semakin bertambah
Zihni | = | Kefahamanku, kekuatan akalku
Zikri | = | Ingatanku, kenanganku
Zimam | = | Yang utama, pemimpin
Ziyad | = | Pertambahan, kelebihan
Zubaidi | = | Pilihanku yang terbaik
Zubari | = | Gagah perkasa, pintar
Zuhair | = | Yang tenang
Zuhairi | = | Yang berseri
Zuhdi | = | Zuhud
Zuhri | = | Kecantikanku
Zuhaily | = | Yang tenang
Zuhnun | = | Yang cerdik
Zulfadhli | = | Yang mempunyai kelebihan
Zulfaqar | = | Nama pedang nabi Muhammad SAW
Zulfan | = | Taman
Zulhilmi | = | Yang sabar dan sopan
Zulhusni | = | Yang mempunyai kebaikan dan kecantikan
Zuljalal | = | Mempunyai kebesaran
Zuljamal | = | Yang mempunyai kecantikan
Zulkarnain | = | Nama seorang raja
Zulkifli | = | Nama seorang nabi
Zulmajid | = | Mempunyai kemuliaan
Zunnur | = | Yang bercahaya
Zunnurain | = | Yang mempunyai dua cahaya